• Welcome to The Wyrmkeep Entertainment Co. Forum.


The forum returns! Still working on tweaks.
Please contact techsupport@wyrmkeep.com to get a forum account.

Main Menu

Game crashes

Started by peter, Aug 17, 2005, 06:19 PM

Previous topic - Next topic


As a normal user, the game consistantly crashes after the intro video (which talks about the humans) but before the game starts where you see the rat beat Riff at the game.  When the game crashes, a message on the xterm says:

Can't open save file

Even though .itelinux exists and I made it world readable/writable/executable.

I then tried to play as root.  This time, the game played.   However, when I try to save a game, it says "there was a problem reading/writing the save game file".  I cannot save games, which makes the game as useless as it was when it crashed.  ;)  Again, /root/.itelinux exists and I made it world rwx-able.

Help!  This looks like a really cute game and my wife and I really want to play it.



A few questions to help us resolve your problem:

Did you install the game as root?

Is the environment variable $HOME set in both cases? (Type "echo $HOME" in a terminal.)

Are there any files in the .itelinux directory?

What kernel version and distribution are you running?


Thanks for getting back to me!

Yes, the game was installed, as root, into /usr/local/games/Inherit the Earth.  Just to make sure that the spaces in the directory name weren't screwinng things up, I renamed "Inherit the Earth/" to "inherit/".

$HOME is indeed set correctly for both the normal user and user root.

Yes, in the directory /home/p/.itelinux, there's one file, named ite.prf.  For the root user, there's only one file, also named /home/p/.itelinux.

The kernel version is 2.6.12, and the distro is Debian Sid (unstable).

I have some more details that might interest you.  I ran the demo (itedemo).  It worked when I played as a normal user (recall that itegame crashed as a normal user).   It looks like the load/save feature of the demo was crippled -- save won't ask for a filename and load doesn't do anything at all.  However... when I quit demo, I noticed there was a file /home/p/.itelinux/ITE.SAV (even though I wasn't able to save the game under the demo.  It wrote a save game file anyhow).

On a hunch, I ran the game itegame, and this time it didn't crash!  I then tried to save a game, and voila, it appears to save the game.

To summarize, the game doesn't seem to be able to save ITE.SAV which causes it to crash.  The demo writes a save game.  After the save game is written by the demo, I can play the full game just fine.


Interesting workaround -- run the demo  :)

I glad you are able to play the game now. We will continue to look into the problem(s) you reported.

One additional question: Is your copy the "April 2005 Release" (as indicated in the text printed at the bottom of the CD below the copyright notice) or an earlier release?


Heh.  I thought that was cute workaround too.   :-)

Yeah -- it says April 2005 release.

Forgot two last things.

First, when playing around last night, I found that it's *not* good enough to simply:

Quotetouch $HOME/.itelinux/ITE.SAV

You actually need the demo to create a proper ITE.SAV file before the full game can continue.

Second, I did a little digging with strace and ltrace.  I didn't find anything that was obviously screwing up (like an open() with a negative return value), but I didn't look that hard either.  If you would like some more diagnostics, I would be more than happy to assist in anyway I can.



We have duplicated the bug. We hope to have a simpler workaround then installing the demo in a couple of days. A program patch will be available sometime later.


Cool.  I'm glad I could be of help.

If this is Joe, I do have one question.  I'm about to graduate with a PhD in physics from UC Davis in a few weeks.  How does one make the transition from physics graduate to game developer?  ;-)  Have to admit... I love and am fascinated by physics (otherwise I wouldn't have gotten this far), but my  heart is in computer games.   :D